QNAP TimeMachine auf OS X Mavericks

Ich hatte, nach Neuinstallation von OS X Mavericks, ein Problem. Und zwar kam ich nicht mehr an meine TimeMachine die auf meiner QNAP Nas läuft. Damit bin ich absolut nicht alleine wie ich beim googlen festgestellt habe.

Das Ganze äußerte sich so, dass man das Volume zwar sehen kann, aber eine Verbindung über die TimeMachine Einstellungen nicht möglich ist. Folglich kommt man nicht an die Backups..

Nach einigem Probieren, Neustarts etc. habe ich mich an tmutil gemacht und versucht das Ganze über den Terminal einzubinden und ggf. verwertbare Fehlermeldungen zu erzeugen. Da ging allerdings alles ohne Probleme und die TimeMachine läuft nun wieder wie vorher – die Lösung dazu teile ich natürlich gerne mit euch.

Zuerst das Terminal öffnen und mit „sudo -s“ eine Root-Shell aufmachen.

Nun mit tmutil das Ziel einstellen – also die QNAP Time-Machine. Meine Qnap heißt „storage“ – ihr müsst den Namen bei euch also entsprechend eurer Umgebung anpassen. Wenn das Ganze erfolgreich ist, solltet ihr nach dem Passwort für das TM-Volume gefragt werden.

tmutil setdestination -ap afp://TimeMachine@storage/TMBackup

Als nächstes müssen die Zuweisungen gemacht werden. Dazu braucht ihr den Namen der Festplatte (in diesem Falle „Macintosh HD“ und den Namen eures Macs.

tmutil associatedisk -a /Volumes/Macintosh HD/ /Volumes/Time Machine Backups/Backups.backupdb/macbook/Latest/Macintosh HD/

Nun das Backup re-aktivieren.. und schon könnt ihr wieder wie gewohnt auf die alten Sicherungen zugreifen. Auch hier muss der Name des Rechners angepasst werden.

tmutil inheritbackup /Volumes/Time Machine Backups/Backups.backupdb/macbook/

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.