Intel SSD 320 – BAD_CTX unter Linux wiederbeleben

Heute hat mich mein Server nicht wie sonst mit einer freudigen SSH Session begrüßt, sondern überhaupt nicht.. Komplett verstorben. Also, schnell auf die iLO geschaut und ein Livesystem gebooted – Die 4 Monate alte Intel SSD ist von mächtigen 40 GB auf 8,4 MB geschrumpft und zeigte anstatt der Seriennummer nur noch BAD_CTX an.

Bildschirmfoto 2015-07-29 um 20.37.01

Kurze Recherche bei Google.. Firmware Bug. Also Firmware-Update-Iso heruntergeladen, über die iLO gebooted – Firmware up to date. Hätte man sich auch sparen können.

Bildschirmfoto 2015-07-29 um 20.23.23

Nun musste hdparm helfen.

sudo -i
root@mint: hdparm -I /dev/sda

Unter Security stand frozen – also wird ein sicheres Löschen der Festplatte nicht funktionieren.
Nochmalige Google-Recherche.. den SATA Stecker im laufenden Betrieb ziehen und wieder stecken „unfreezed“ die Platte und danach sollte man Zugriff auf die Firmware-Funktionen zum sicheren Löschen der HDD haben.. Also, Server ausgebaut, aufgeschraubt, SATA Stecker gezogen, kurz gewartet – erneut geprüft. Voila.. Access granted 🙂

Security:
Master password revision code = 65534
supported
enabled
not locked
not frozen
not expired: security count
supported: enhanced erase
Security level high
2min for SECURITY ERASE UNIT. 2min for ENHANCED SECURITY ERASE UNIT.

Als nächstes muss man einen User und ein Passwort für das sichere Löschen festlegen.

hdparm –user-master u –security-set-pass 12345 /dev/sda

Und das Kommando für das sichere löschen absetzen.

hdparm –user-master u –security-erase 12345 /dev/sda

Alternativ:

sudo hdparm –user-master u –security-erase-enhanced 12345 /dev/sda

Danach war die Festplatte wieder auf die ursprünglichen 40 GB angewachsen und ich konnte mich an die Neuinstallation des Betriebssystems machen.

Bildschirmfoto 2015-07-29 um 21.07.50
War wohl trotzdem die letzte Intel SSD die ich mir gekauft habe. Die schleppen diesen Bug seit 2009 in Ihrer Firmware mit sich herum. Angeblich tritt es oft nach einem Stromausfall auf – mein Server hängt aber samt Shutdown-Agents an einer USV und laut Logs gab es noch nie einen Stromausfall..

Ich hoffe, es hilft dem ein oder anderen.

Quelle (unter anderem): http://askubuntu.com/questions/409684/image-or-reset-broken-ssd

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.